Nothing saving to database


#21

Thanks for reporting it @lowndsy! I’ve restarted things and confirmed they’re working again.


#22

I think I just ran into this issue too - There’s no errors, and it saves to a .sqlite on my local machine, but the scraper isn’t saving anything to Sqlite on Morph.io:

https://morph.io/alisonkeen/SA_MHRS_for_OA_input

Have I missed something important or is it just that something needs a restart?


#23

Not your fault @alisonkeen, it’s a morph bug that we haven’t got to the bottom of. I’ve restarted the queue and it’s fixed now.


#24

Thankyou - looks all good now! - A


#25

The same thing again


#26

@achasik I just ran the test scraper and it seems to be working OK:

1 record added, 1 record removed in the database


#27

My scraper didn’t save anything last night (~8pm GMT) or just now when I manually reran. Looks like the old problem is back…


#28

@lowndsy thanks for reporting this. I’ve run the test scraper and it’s working OK. I’ve restarted Sidekiq anyway, can you please try again and let us know if it’s working for you?


#29

Thanks, looks fine again now.


#30

Happy Monday everyone. I’m afraid the saving issue is back for me again. Just tried twice and nothing changed in the database.


#31

Happy Monday! :sunny: I’ve restarted the queue and verified it’s working again.

The good news is that we should have someone working on fixing this issue this week.


#32

I’m having the same problem with this scraper: https://morph.io/everypolitician-scrapers/guernsey-2016


#33

@ondenman hmm, not seeing the problem with the test scraper this time but I’ve restarted the queue anyhow.


#34

Sorry, looks like it is back - nothing saved to database for my last two scrapes.


#35

Oops, nothing saved too to database for ukraine_verkhovna_rada_votes more details https://github.com/openaustralia/ukraine_verkhovna_rada_votes/issues/17


#36

nothing changed in the database again


#37

We’ve fixed that problem and also addressed the big backlog of scrapers that started happening about 3 days ago.

You can read what we did on the issue: https://github.com/openaustralia/morph/issues/1064#issuecomment-255626498

There is still a backlog of over 600 runs right now but morph.io is working its way through them.


My scraper stuck, what to do?
#38

The problem still remain


#39

You’re right @achasik, thanks for letting us know. I’ve updated the issue with what I’ve been doing to fix it https://github.com/openaustralia/morph/issues/1064#issuecomment-255895896


#40

Good Morning Gents. It looks like things aren’t saving again - failed over the weekend and I have just re-ran with the same result.