Scraper stuck on creating github repository


A scraper I’ve tried to create has stuck at the creating GitHub repository stage:

Is there anything I can do do fix this?



There is no way to solve this as a user - it needs a helpful admin to come along and sort it out for you

Hi @struan . I’ve deleted the scraper record so you can create it again.

Over the last month this only seems to be happening to scrapers created on the everypolitician-scrapers organization (this is from memory, not hard data). We see Github return a 403 error “You need admin access to the organization before adding a repository to it.” Can you confirm that you do have admin access to the organization? That’ll help us track down this issue.


Thanks for that. I’ve double checked that I am an owner for that organization and re-tried to create the scraper and it’s hung again at the same point. There’s nothing in the Audit Log that I can see about the scraper.

I tried logging out and logging in again and creating a new one and that was also unsuccessful I’m afraid so now I have:

Thanks again,


I’ve got the same issue with an org where I am the owner:

It never really got resolved - I’m unclear whether it is a GitHub issue or a morph issue. I just create scrapers under that org using ‘import from github’, but it would be convenient if we could work out what the issue is.

Thanks for reporting this @chris48s and @struan . I’ve made a Github issue for trying to track this down in morph

@struan I’ll delete those scrapers for you. @chris48s seems to have found a work around in the meantime over here Scraper stuck on ‘Creating GitHub repository’

You might be able to use that to get around it for now, once I’ve deleted the existing scrapers for you.

once I’ve deleted the existing scrapers for you.