Scraper stuck on 'Creating GitHub repository'


I tried to create some new scrapers at and but they are both stuck on ‘Creating GitHub repository’.

I’ve created scrapers ok under my own github username, so I’m guessing that maybe there’s some permissions issue with creating the scraper under this organisation namespace? I guess I have 2 questions/requests:

  1. Is there some setting or permission I need to change to allow morph to create repositories in this github organisation? My user account is already the organisation owner.
  2. Can someone reset/delete the 2 scrapers I’ve tried to create.


Scraper stuck on creating github repository

Quick update on this - I’ve now managed to create some scrapers in my organisation by creating repositories on github first and then importing via (instead of trying to create the repositories through morph) so if it isn’t obvious what I need to change, just delete the 2 that are stuck and I can make my scrapers like this in future.

Scraper stuck on creating github repository

Apologies for bumping this, but would it be possible to get these 2 deleted - I’d like to be able to import scrapers at these urls and keep my naming convention.


@chris48s first up, sorry for the problems you had with the forums marking your posts as spam. Discourse has pretty aggressive anti-spam stuff. I’ve whitelisted so hopefully it’ll be a little less overbearing about posts with links.

After much fiddling on the console I’ve tried to rerun the scraper creation process. The problem is hitting is this bug:

Which is caused by the permissions on your GitHub repository. The error I can see is this one:

Octokit::Forbidden: POST 403 - You need admin access to the organization before adding a repository to it. // See:

If you fix up the GitHub permissions I can rerun the manual thing on the console to try creating these scrapers.

To save me typing and working it out next time, this magic should work on the console:
  Scraper.find_by(full_name: "wdiv-scrapers/DC-PollingStations-Doncaster").id,
  User.find_by(nickname: "chris48s").id,


Hi Henare,
Thanks for responding. Whitelisting on discourse’s spam filter is probably a sensible move :slight_smile:

I appreciate your explanation of the problem. Looking at the organisation permissions for my account on the wdiv-scrapers organisation:

As an owner, chris48s has admin access to all repositories that belong to the wdiv-scrapers organization.

…I can’t see what I can change that would give my account any higher level of access to the organisation than that.

As I say in my second post, I’m perfectly happy to just create repositories on github and import them (as I’ve done with my other 32 working scrapers) rather than have morph create the repos for me - I’d just like to free up the names:
so I can create github repos myself and import them into morph with those names. Is there any chance you could just delete those 2 scrapers?



I was hoping to fix the deeper problem but meh, I’ve just done this now :slight_smile:


Thanks Henare,
I’d also ideally like to know what I need to change in my organisation permissions, but as I say I can’t see what else I can grant. Perhaps someone else who creates scrapers under a GitHub org rather than their own namespace might be able to let me know what I’m missing.