Get help with morph.io and scraping

PHP error - Failed to download minimal PHP for bootstrapping

All of my PHP scrapers are failing - I get the following message:
No code has changed for weeks, been getting this for the last 48 hours or so:

Injecting configuration and compiling…
e[1G e[1G-----> PHP app detected
e[1G-----> Bootstrapping…
e[1G
e[1G ! ERROR: Failed to download minimal PHP for bootstrapping.
e[1G Please try again, or contact support if this problem persists.
e[1G

Check out https://morph.io/planningalerts-scrapers/townsville

Looks like you need to create a file called ‘platform’ with a single line text ‘early_release’ in it.

@jamezpolley, can you add some doc on the web site please when you have a chance?

Well that did something, but I’m afraid it isn’t working.

I get…

Injecting configuration and compiling…
Injecting scraper and running…
PHP Warning: preg_match(): Compilation failed: invalid range in character class at offset 4 in /app/vendor/openaustralia/scraperwiki/simple_html_dom.php on line 1364

That PHP error error then repeated hundreds of times and filled up the 10000 line buffer before failing.

I tried creating a compeletely empty “platform” file on another scraper, and that is running with no messages at all but looks to have hung.

Seems the platform file is key, but I don’t know what to put in to make dependencies like SimpleHTMLDOM work again.

Just tried creating a new php scraper but that has the same problem.
Is anyone else getting this?

I’ve created https://github.com/openaustralia/morph/projects/1#card-23722065 to track this.

I think this isThis definitely isn’t the error I worked around in https://github.com/planningalerts-scrapers/KingboroughCouncil/commit/458f141d480ebda7332dd86f2294c95edf54331c (updating dependencies to a new version of the dom parser) and https://github.com/planningalerts-scrapers/KingboroughCouncil/commit/6147b13fc1229b7daf29150efe0337b3333fb4c9 (which updates the code to use the new dom parser)

But I would suggest updating to use the dom parser I used there rather than the simple_html_dom.php, which is unfortunately about 6 years old at this point and hasn’t kept up with the php versions available on the newer platform.

When I had to make changes, it took me a while to figure out how to update Composer.lock. I ended up documenting the solution I used at I don't usually develop PHP; how can I update composer.lock? but there are probably simpler ways to do it.

Could you point me at this so I can take a look? We have an issue open already for Ruby scrapers not generating output (https://github.com/openaustralia/morph/projects/1#card-23721926); I think we need another one for PHP.

Np, it’s here: